Console Output

Started by upstream project "wwiv" build number 3546

originally caused by:

Started by an SCM change

Running as SYSTEM

Building remotely on debian10-ws (linux-debian10 linux debian10) in workspace /jenkins/workspace/wwiv/label/linux-debian10

The recommended git tool is: NONE

No credentials specified

> git rev-parse --resolve-git-dir /jenkins/workspace/wwiv/label/linux-debian10/.git # timeout=10

Fetching changes from the remote Git repository

> git config remote.origin.url https://github.com/wwivbbs/wwiv.git # timeout=10

Fetching upstream changes from https://github.com/wwivbbs/wwiv.git

> git --version # timeout=10

> git --version # 'git version 2.20.1'

> git fetch --tags --force --progress -- https://github.com/wwivbbs/wwiv.git +refs/heads/*:refs/remotes/origin/* # timeout=10

Checking out Revision 98f268dc7304c18155a6cfe53e9f34d94580fb64 (refs/remotes/origin/main)

> git config core.sparsecheckout # timeout=10

> git checkout -f 98f268dc7304c18155a6cfe53e9f34d94580fb64 # timeout=10

Commit message: "Since tests are in bbs, not bbs_test, update copy command"

> git rev-list --no-walk adf95360ca87b9ff849db2dde108c17f758a4f62 # timeout=10

> git remote # timeout=10

> git submodule init # timeout=10

> git submodule sync # timeout=10

> git config --get remote.origin.url # timeout=10

> git submodule init # timeout=10

> git config -f .gitmodules --get-regexp ^submodule\.(.+)\.url # timeout=10

> git config --get submodule.deps/my_basic.url # timeout=10

> git config -f .gitmodules --get submodule.deps/my_basic.path # timeout=10

> git config --get submodule.deps/pdcurses.url # timeout=10

> git config -f .gitmodules --get submodule.deps/pdcurses.path # timeout=10

> git config --get submodule.vcpkg.url # timeout=10

> git config -f .gitmodules --get submodule.vcpkg.path # timeout=10

> git submodule update --init --recursive deps/my_basic # timeout=10

> git submodule update --init --recursive deps/pdcurses # timeout=10

> git submodule update --init --recursive vcpkg # timeout=10

[linux-debian10] $ ./builds/jenkins/wwiv/build

=============================================================================

Workspace: /jenkins/workspace/wwiv/label/linux-debian10

CMake: cmake; Test: ctest; Pack: cpack

CMake Build: /jenkins/workspace/wwiv/label/linux-debian10/_build

Release Dir: /jenkins/workspace/wwiv/label/linux-debian10/_build/release

WWIV Release: 5.8.0.3546

Archive: wwiv-linux-debian10-5.8.0.3546.tar.gz

WWIV_DISTRO: linux-debian10

GCC: gcc (Debian 8.3.0-6) 8.3.0

=============================================================================

rm: cannot remove '/jenkins/workspace/wwiv/label/linux-debian10/wwiv-*.tar.gz': No such file or directory

rm: cannot remove '/jenkins/workspace/wwiv/label/linux-debian10/_build/wwiv-*.tar.gz': No such file or directory

Creating /jenkins/workspace/wwiv/label/linux-debian10/_build and /jenkins/workspace/wwiv/label/linux-debian10/_build/release

+ echo 'Building binaries'

Building binaries

+ pushd /jenkins/workspace/wwiv/label/linux-debian10/_build

/jenkins/workspace/wwiv/label/linux-debian10/_build /jenkins/workspace/wwiv/label/linux-debian10

+ cmake -G Ninja -DCMAKE_BUILD_TYPE=Debug -DWWIV_RELEASE=5.8.0 -DWWIV_ARCH= -DWWIV_BUILD_NUMBER=3546 -DWWIV_DISTRO=linux-debian10 /jenkins/workspace/wwiv/label/linux-debian10

-- Running vcpkg install

-- Running vcpkg install - done

-- The C compiler identification is GNU 8.3.0

-- The CXX compiler identification is GNU 8.3.0

-- Check for working C compiler: /usr/bin/cc

-- Check for working C compiler: /usr/bin/cc -- works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Detecting C compile features

-- Detecting C compile features - done

-- Check for working CXX compiler: /usr/bin/c++

-- Check for working CXX compiler: /usr/bin/c++ -- works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- Detecting CXX compile features

-- Detecting CXX compile features - done

VERBOSEWWIV Common CMake Module.

-- Set CPACK_PACKAGE_FILE_NAME: wwiv-linux-debian10-5.8.0.3546

-- Set CPACK_PACKAGE_VERSION: 5.8.0

-- WWIV Build Number: 5.8.0.3546

VERBOSECMAKE_BUILD_TYPE: Debug

VERBOSECMAKE_CXX_FLAGS:

VERBOSEDefining _DEBUG macro for debug build

-- Performing Test HAVE_FLAG_ADDRESS_SANITIZER

-- Performing Test HAVE_FLAG_ADDRESS_SANITIZER - Failed

-- Performing Test HAVE_FLAG_SANITIZE_ADDRESS

-- Performing Test HAVE_FLAG_SANITIZE_ADDRESS - Success

CMake Error at cmake/Common.cmake:69 (message):

Require at least gcc-10.0; found: 8.3.0

Call Stack (most recent call first):

CMakeLists.txt:22 (ENSURE_MINIMUM_COMPILER_VERSIONS)

-- Configuring incomplete, errors occurred!

See also "/jenkins/workspace/wwiv/label/linux-debian10/_build/CMakeFiles/CMakeOutput.log".

See also "/jenkins/workspace/wwiv/label/linux-debian10/_build/CMakeFiles/CMakeError.log".

+ exit /b

./builds/jenkins/wwiv/build: line 51: exit: /b: numeric argument required

Build step 'Invoke XShell command' marked build as failure

Skipped archiving because build is not successful

INFO: Processing CTest-Version 3.x (default)

ERROR: Step ‘Publish xUnit test result report’ failed: [CTest-Version 3.x (default)] - No test report file(s) were found with the pattern '_build/Testing/**/*.xml' relative to '/jenkins/workspace/wwiv/label/linux-debian10' for the testing framework 'CTest-Version 3.x (default)'.

Did you enter a pattern relative to (and within) the workspace directory?

Did you generate the result report(s) for 'CTest-Version 3.x (default)'?"

Finished: FAILURE